Home > FAQs > Registration > ORS System Requirements and Security Managers > What are the system requirements...

What are the system requirements for ORS?

ORS requires a currently supported version of Microsoft Internet Explorer or Firefox, and you must enable cookies and Scripting of Java Applets. If you can use the CRD system or transact business on the Internet on web sites like Amazon.com, you should be able to use ORS. Contact your network administrator, use the Help function or visit the web sites listed below to determine if your system supports these requirements.

Internet Explorer updates are available at:

http://www.microsoft.com/windows/ie

Firefox updates are available at:

http://www.mozilla.com/en-US/

NFA is the premier independent provider of efficient and innovative regulatory programs that safeguard the integrity of the futures markets.
Site Index | Contact NFA | News Center | FAQs | Career Opportunities | Industry Links | Home
© National Futures Association All Rights Reserved. | Disclaimer and Privacy Policy